<!doctype html><html lang="en" prefix="og: https://ogp.me/ns#" style="--headerFullHeight: 90px; --headerHeight: 90px;"><head><meta charset="utf-8"><title data-static-tag-from="prerender">Live Nation jumps 7% as analysts look to concert rebound | Seeking Alpha</title><link rel="preconnect" href="https://static.seekingalpha.com"><link rel="preconnect" href="https://static1.seekingalpha.com"><link rel="preconnect" href="https://static2.seekingalpha.com"><link rel="preconnect" href="https://static3.seekingalpha.com"><link rel="preconnect" href="https://www.googletagmanager.com" crossorigin="anonymous"><link rel="preconnect" href="https://www.google-analytics.com" crossorigin="anonymous"><meta name="viewport" content="width=device-width,initial-scale=1,viewport-fit=cover"><meta content="ie=edge" http-equiv="X-UA-Compatible"><meta name="application-name" content="SeekingAlpha"><meta name="HandheldFriendly" content="true"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-title" content="SeekingAlpha"><meta name="apple-mobile-web-app-status-bar-style" content="black"><meta name="format-detection" content="telephone=yes"><meta name="theme-color" content="#333333"><meta property="fb:app_id" content="159723149420031"><meta property="fb:pages" content="224867310939090"><meta content="SeekingAlpha" property="al:ios:app_name"><meta content="552799694" property="al:ios:app_store_id"><meta content="SeekingAlpha" property="al:android:app_name"><meta content="com.seekingalpha.webwrapper" property="al:android:package"><meta name="google-site-verification" content="8arRaWMkVniCnxJWf9hbm-0PYkb_LhjaXAk7rGd97iw"><meta name="msvalidate.01" content="0FEA0055AC330065CFA87CA3045E9860"><meta property="og:locale" content="en_US"><meta property="og:site_name" content="SeekingAlpha"><link rel="mask-icon" href="/samw/static/images/favicon.svg" color="#ff7200"><link rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon.png"><link sizes="57x57" rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon-57x57.png"><link sizes="60x60" rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon-60x60.png"><link sizes="72x72" rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon-72x72.png"><link sizes="76x76" rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon-76x76.png"><link sizes="114x114" rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon-114x114.png"><link sizes="120x120" rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon-120x120.png"><link sizes="144x144" rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon-144x144.png"><link sizes="152x152" rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon-152x152.png"><link sizes="180x180" rel="apple-touch-icon" href="/samw/static/images/apple-touch-icon-180x180.png"><link sizes="16x16" rel="icon" type="image/png" href="/samw/static/images/favicon-16x16.png"><link sizes="32x32" rel="icon" type="image/png" href="/samw/static/images/favicon-32x32.png"><link sizes="32x32" rel="icon" type="image/png" href="/samw/static/images/favicon-96x96.png"><link sizes="192x192" rel="icon" type="image/png" href="/samw/static/images/favicon-192x192.png"><link href="/samw/favicon.ico" rel="icon"><style data-href="/samw/static/styles/app.fcd15a2e.css">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</style><style data-href="/samw/static/styles/prerender.c5fefd07.css">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</style><meta name="theme-color" content="#333333" ><link rel="manifest" href="/samw/manifest.e3ca8fbeb83bff354aee75d40707da84.json" ><link as="script" href="/samw/static/js/app.5cbcc155.js" rel="preload" ><link as="script" href="/samw/static/js/c.4429.3547f4b3.js" rel="preload" ><link as="script" href="/samw/static/js/c.5256.99594c40.js" rel="preload" ><link as="script" href="/samw/static/js/c.1486.85dda872.js" rel="preload" ><link as="script" href="/samw/static/js/c.1857.32007086.js" rel="preload" ><link as="script" href="/samw/static/js/c.1588.b1926685.js" rel="preload" ><link as="script" href="/samw/static/js/c.6838.1c274657.js" rel="preload" ><link as="script" href="/samw/static/js/c.9939.1d655728.js" rel="preload" ><link as="script" href="/samw/static/js/c.9377.b2237225.js" rel="preload" ><link as="script" href="/samw/static/js/c.6697.bed7f85d.js" rel="preload" ><link as="script" href="/samw/static/js/c.7905.18262862.js" rel="preload" ><link as="script" href="/samw/static/js/c.2454.1c14eafc.js" rel="preload" ><link as="script" href="/samw/static/js/c.3379.8b4f913e.js" rel="preload" ><link as="script" href="/samw/static/js/c.Article-S.72f428c0.js" rel="preload" ><link as="style" href="/samw/static/styles/9377.655e9395.css" rel="preload" ><link as="style" href="/samw/static/styles/Article-S.436adca7.css" rel="preload" ><link as="fetch" crossorigin="" href="/api/v3/breaking_news" rel="preload" type="application/json" ><meta content="Live Nation Entertainment (LYV) is up 6.7% after yesterday&#39;s Q1 earnings, where the company edged some heavily lowered revenue expectations and began to plot its way out of..." name="description" ><meta content="noarchive" name="robots" ><link href="https://seekingalpha.com/amp/news/3693503-live-nation-stock-jumps-7-amid-signs-of-life-as-analysts-look-to-concert-rebound" rel="amphtml" ><meta content="Live Nation jumps 7% as analysts look to concert rebound" name="twitter:title" ><meta content="Live Nation Entertainment (LYV) is up 6.7% after yesterday&#39;s Q1 earnings, where the company edged some heavily lowered revenue expectations and began to plot its way out of..." name="twitter:description" ><meta content="summary" name="twitter:card" ><meta content="@SeekingAlpha" name="twitter:site" ><meta content="https://static.seekingalpha.com/assets/og_image_1200-29b2bfe1a595477db6826bd2126c63ac2091efb7ec76347a8e7f81ba17e3de6c.png" name="twitter:image" ><meta content="Live Nation jumps 7% as analysts look to concert rebound" property="og:title" ><meta content="Live Nation Entertainment (LYV) is up 6.7% after yesterday&#39;s Q1 earnings, where the company edged some heavily lowered revenue expectations and began to plot its way out of..." property="og:description" ><meta content="article" property="og:type" ><meta content="https://seekingalpha.com/news/3693503-live-nation-stock-jumps-7-amid-signs-of-life-as-analysts-look-to-concert-rebound" property="og:url" ><link href="https://seekingalpha.com/javascripts/seeking.xml" rel="search" title="Live Nation jumps 7% as analysts look to concert rebound" type="application/opensearchdescription+xml" ><link href="https://seekingalpha.com/news/3693503-live-nation-stock-jumps-7-amid-signs-of-life-as-analysts-look-to-concert-rebound" rel="canonical" ><meta content="https://static.seekingalpha.com/assets/og_image_1200-29b2bfe1a595477db6826bd2126c63ac2091efb7ec76347a8e7f81ba17e3de6c.png" property="og:image" ><script>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</script><link href="/samw/static/styles/9377.655e9395.css" rel="stylesheet" ><link href="/samw/static/styles/Article-S.436adca7.css" rel="stylesheet" ><script>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</script></head><body><div class="appLoading invisible" id="app-loader"></div><span><svg style="position:absolute;width:0;height:0" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><symbol viewBox="0 0 34 28" id="alpha"><path d="M28.77 24.7c3.44 2.03 3.64-3.92 3.64-3.92.75-.28 1.22-.5 1.22-.5 1.82 8.27-3.64 7.7-3.64 7.7-4.26.42-6.08-6.03-6.08-6.03-6.02 7.4-12.96 5.8-12.96 5.8C-.95 26.33.02 13.99.02 13.99.96.29 12.5 0 12.5 0c8.35.06 10.72 8.35 10.72 8.35.11.46 4.95-7.77 4.95-7.77h2.74c-5.58 11.31-5.35 15.94-5.35 15.94-.46 6.08 3.2 8.18 3.2 8.18zM5 13.99c0 6.4 3.44 11.67 8 11.54 6.41-.19 8.26-5.2 8.26-11.6 0-6.4-3.7-11.65-8.26-11.6C7.38 2.4 5 7.6 5 14z"></path></symbol><symbol viewBox="0 0 20 24" id="bell"><path d="M16.88 10.49c0-3.54-2.02-5.98-3.54-6.4-1.52-.43-1.46-2.05-1.46-2.05C11.88.91 11.04 0 10 0S8.12.91 8.12 2.04c0 0 .06 1.62-1.46 2.05-1.52.42-3.54 2.86-3.54 6.4C3.12 18 0 17.56 0 20.16h20c0-2.6-3.12-2.15-3.12-9.67zM6.46 21.12A3.72 3.72 0 0010 24a3.7 3.7 0 003.54-2.88H6.46z"></path></symbol><symbol viewBox="0 0 31 25" id="chat"><path d="M28.92 5.18a14.04 14.04 0 00-5.64-3.79A21.22 21.22 0 0015.5 0c-2.1 0-4.1.28-6.02.82a17.31 17.31 0 00-4.95 2.22 11.4 11.4 0 00-3.3 3.33A7.42 7.42 0 000 10.41c0 1.63.52 3.16 1.57 4.58a12.47 12.47 0 004.28 3.58 9.93 9.93 0 01-1.48 3.02c-.17.23-.35.44-.54.65l-.6.62a56.87 56.87 0 00-.67.7l-.12.14-.1.15c-.06.08-.09.13-.08.15a.3.3 0 01-.04.16c-.03.1-.02.16.01.2v.02c.04.18.15.35.3.47a.7.7 0 00.53.14A19.33 19.33 0 0013 20.7c.87.1 1.7.14 2.51.14 2.81 0 5.41-.46 7.78-1.4a13.88 13.88 0 005.64-3.78A7.84 7.84 0 0031 10.4c0-1.88-.7-3.63-2.08-5.23z"></path></symbol><symbol viewBox="0 0 5 21" id="info"><circle cx="2.5" cy="2.5" r="2.5"></circle><circle cx="2.5" cy="10.5" r="2.5"></circle><circle cx="2.5" cy="18.5" r="2.5"></circle></symbol><symbol viewBox="0 0 9 10" id="lock"><path d="M7.77 4.36h-.36V3.08A3 3 0 004.5 0a3 3 0 00-2.9 3.08v1.28h-.37c-.4 0-.73.34-.73.77v4.1c0 .43.33.77.73.77h6.54c.4 0 .73-.34.73-.77v-4.1a.75.75 0 00-.73-.77zm-5.12 0V3.08A1.9 1.9 0 014.5 1.12a1.9 1.9 0 011.85 1.96v1.28h-3.7z"></path></symbol><symbol viewBox="0 0 131 26" id="logo"><path fill="currentColor" d="M.4 18a9.26 9.26 0 01-.4 1.82C.7 20.58 2.34 21 3.34 21c2.8 0 5.07-1.74 5.07-4.68 0-4.37-6.46-2.85-6.46-6.63 0-1.45 1.17-2.4 2.58-2.4 1.21 0 2.12.68 2.55 1.79h.2c.17-.58.31-1.15.56-1.68a4.6 4.6 0 00-2.94-.99c-2.46 0-4.55 1.3-4.55 3.94 0 4.64 6.42 2.95 6.42 6.77 0 1.62-1.19 3-2.85 3-1.6 0-2.52-.82-3.32-2.14H.4zm11.33-3.28c.12-1.73.96-3.57 2.9-3.57 2.02 0 2.52 1.78 2.56 3.57h-5.46zm6.59 3.6a4.55 4.55 0 01-3.04 1.42c-2.48 0-3.73-1.97-3.55-4.27h2.9c1.37 0 2.76.02 4.16.07.2-3.43-1.89-5.03-4.17-5.03-3.05 0-4.7 2.2-4.7 5.05 0 3.18 2.02 5.04 4.85 5.04 1.25 0 2.52-.49 3.52-1.2l.03-1.08zm3.92-3.6c.12-1.73.96-3.57 2.9-3.57 2.02 0 2.52 1.78 2.56 3.57h-5.46zm6.58 3.6a4.54 4.54 0 01-3.03 1.42c-2.48 0-3.74-1.97-3.55-4.27h2.9c1.37 0 2.76.02 4.16.07.2-3.43-1.9-5.03-4.17-5.03-3.05 0-4.7 2.2-4.7 5.05 0 3.18 2.02 5.04 4.85 5.04 1.25 0 2.52-.49 3.53-1.2l.01-1.08zm3.77-13.07c-.31.03-.56.07-.83.07-.28 0-.55-.04-.82-.07v15.41c.27-.02.54-.06.82-.06.27 0 .52.04.83.06v-4.18c0-.89.28-.95.73-.43 1.32 1.5 2.94 3.32 3.92 4.61.33-.02.66-.06 1.03-.06.33 0 .61.04 1 .06v-.1c-1.62-1.85-3.34-3.9-4.82-5.6 1.9-1.79 3.7-3.22 4.52-3.96v-.14c-.31.01-.56.06-.8.06-.3 0-.56-.05-.82-.06l-1.6 1.76-1.28 1.3c-.26.26-1.35 1.43-1.78 1.2-.19-.1-.1-.4-.1-.67v-9.2zm10.37 2.22c0-.58-.5-1.05-1.04-1.05a1.05 1.05 0 000 2.1c.55 0 1.04-.48 1.04-1.05zm-.22 3.5c-.31.03-.56.07-.82.07-.3 0-.56-.04-.83-.06v9.8c.27-.02.54-.06.83-.06.26 0 .5.04.82.06v-9.8zm1.63 9.47c.27-.02.54-.06.82-.06.27 0 .52.04.82.06v-4.76c0-2.53.54-4.1 2.7-4.1 1.92 0 2.27 1.5 2.27 3.4v5.46c.26-.02.53-.06.82-.06.26 0 .51.04.82.06V14.5c0-2.7-.92-4-3.3-4-1.46 0-2.59.74-3.3 1.99v-1.87c-.31.02-.56.06-.83.06-.28 0-.55-.04-.82-.06v9.8zm11.21-6.68c0-1.56.84-2.7 2.32-2.7 1.62 0 2.2 1.22 2.2 2.8 0 1.4-.79 2.69-2.28 2.69-1.5 0-2.3-1.34-2.24-2.8zm6.9-3.18c-.48.08-.97.1-1.47.04l-2.85-.1c-2.99-.1-4.14 1.27-4.14 3.26 0 1.51.76 2.36 1.99 2.93-.8.35-1.41.78-1.41 1.77 0 1.25.65 1.55 1.25 1.66v.16c-1.28.23-2.14 1-2.14 2.48 0 2.16 2.03 3.02 3.72 3.02 3.13 0 5.2-1.64 5.2-4.04 0-1.75-1.12-2.73-3.54-2.73h-1.32c-1.23 0-1.97-.12-1.97-.99 0-1.19 1.24-.98 1.48-.98 2.38 0 4.37-.95 4.37-3.18 0-1.15-.57-2.05-1.41-2.7l2.25.18v-.78zm-4.34 9.7c1.54 0 3.02.14 3.02 2.28 0 1.93-1.77 2.62-3.24 2.62-1.7 0-2.95-.82-2.95-2.48 0-1.66 1.04-2.44 3.17-2.42zm19.16-5.92h-4.5l2.23-5.25 2.28 5.25zm-1.53-7.94h-.47l-6.4 14.34c.22-.02.45-.06.71-.06.25 0 .47.04.76.06.58-1.93 1.32-3.73 2.03-5.54h5.21a77.59 77.59 0 012.16 5.54c.35-.02.7-.06 1.09-.06.34 0 .67.04 1.06.06L75.77 6.42zm7.73 14.24c.26-.02.52-.06.81-.06.27 0 .51.04.82.06V5.26c-.3.02-.55.06-.82.06-.29 0-.55-.04-.82-.07v15.41zm5.13-2.03h.04c.68 1.28 1.69 1.97 3.16 1.97 2.63 0 4.43-2.03 4.43-5.4 0-2.45-1.47-4.7-4.12-4.7-2.48 0-3.12 1.5-3.47 2.2h-.04v-2.07c-.3.02-.55.06-.82.06-.28 0-.55-.04-.82-.06V25.7c.27-.02.54-.06.82-.06.27 0 .52.04.82.06v-7.06zm0-2.83c0-1.9.62-4.6 3-4.6 2.21 0 2.83 2.08 2.83 4.09 0 2.38-.74 4.45-2.81 4.45-2.1 0-3.02-1.74-3.02-3.94zm9.46 4.86c.26-.02.53-.06.82-.06.26 0 .51.04.82.06v-5.58c0-2.13.84-3.28 2.68-3.28 1.75 0 2.28 1.13 2.28 3.4v5.46c.27-.02.53-.06.82-.06.27 0 .52.04.82.06v-5.93c0-2.58-.92-4-3.3-4-1.45 0-2.58.74-3.3 2V5.24c-.31.03-.56.07-.82.07-.29 0-.56-.04-.82-.07v15.41zm15.23-2.34c0 .15-.41.5-.56.64-.39.4-1.08.78-1.64.78-1.25 0-2-.63-2-1.93 0-1.86 2.08-2.07 3.48-2.34l.72-.14v3zm1.64-4.36c0-2.32-1.17-3.45-3.33-3.45-1.2 0-2.31.45-3.3 1.13v1.15h.23c.14-.45.94-1.42 2.44-1.42 1.54 0 2.4.88 2.4 2.4 0 .99-.56 1.1-2.18 1.38-1.93.3-3.8.61-3.8 2.95 0 1.52 1.28 2.5 2.74 2.5 1.23 0 2.17-.43 3.03-1.29l.19-.18c.16 1.2 1.05 1.37 2.11 1.19.23-.04.47-.15.62-.2v-.46c-1.21.27-1.15-.14-1.15-.94v-4.76z"></path><path color="currentColor" d="M116.78 6.12c.38-5.99 5.1-6.12 5.1-6.12 3.4.02 4.37 3.65 4.37 3.65.04.2 2.02-3.4 2.02-3.4h1.12c-2.28 4.95-2.19 6.98-2.19 6.98-.19 2.66 1.31 3.57 1.31 3.57 1.4.9 1.49-1.71 1.49-1.71.3-.12.5-.22.5-.22.74 3.62-1.49 3.37-1.49 3.37-1.74.18-2.48-2.64-2.48-2.64-2.46 3.24-5.3 2.54-5.3 2.54-4.85-.62-4.45-6.02-4.45-6.02m2.03 0c0 2.8 1.4 5.1 3.26 5.05 2.62-.08 3.38-2.27 3.38-5.08 0-2.8-1.51-5.1-3.38-5.07-2.3.03-3.26 2.3-3.26 5.1"></path></symbol><symbol fill="none" viewBox="0 0 14 12" id="premium"><path stroke="#00D885" d="M9 2h4v4"></path><path stroke="#00D885" d="M13 2L7.24 7.65 5.32 5.76 1 10"></path></symbol><symbol viewBox="0 0 22 26" id="presentation"><path fill-rule="evenodd" clip-rule="evenodd" d="M9 0h4v2H9V0zm4 9a1 1 0 011-1h3a1 1 0 110 2h-3a1 1 0 01-1-1zm0 3a1 1 0 011-1h3a1 1 0 110 2h-3a1 1 0 01-1-1zm-4 5v2h.14l-4.79 4.8c-.3.29-.3.77 0 1.07.29.3.77.3 1.06 0L11 19.28l5.59 5.6a.76.76 0 001.06-1.09L12.85 19H13v-2h7a1 1 0 001-1V5h1V3H0v2h1v11a1 1 0 001 1h7zM19 6H3v9h16V6zm-9.5 6.67A3 3 0 0010 11H7V8a3 3 0 102.5 4.67z"></path><path opacity=".5" d="M11 10a3 3 0 00-3-3v3h3z"></path></symbol><symbol viewBox="0 0 23 16" id="pressRelease"><path fill-rule="evenodd" d="M16.52 3.16a.5.5 0 00.03.7l.15.14c.2.2.52.18.7-.02l2.61-2.8a.5.5 0 00-.03-.7l-.14-.14a.5.5 0 00-.71.03l-2.6 2.79zM1.21 8.1l9.96-6.64c.15-.16.31-.28.5-.34 1.27-.38 3.1 1.88 4.07 5.06.97 3.18.73 6.08-.55 6.46-.19.06-.39.06-.6 0l-3.25.02a3.01 3.01 0 11-6.02.04l-2.7.01c-.64.2-1.47-.68-1.86-1.95C.37 9.49.57 8.3 1.21 8.1zm5.32 4.59a1.8 1.8 0 002.33 1.9 1.8 1.8 0 001.27-1.92l-3.6.02zm8.05-6.16c.78 2.55.9 4.77.26 4.96-.64.2-1.78-1.7-2.56-4.25s-.9-4.77-.26-4.96c.64-.2 1.79 1.7 2.56 4.25zm3.94-1.2a.5.5 0 00-.33.63l.06.2a.5.5 0 00.62.32l3.65-1.11a.5.5 0 00.33-.63l-.06-.2a.5.5 0 00-.62-.33l-3.65 1.12zm-.44 3.1a.5.5 0 01.6-.37l3.72.86a.5.5 0 01.37.6l-.04.2a.5.5 0 01-.6.38l-3.72-.86a.5.5 0 01-.38-.6l.05-.2z"></path></symbol><symbol viewBox="0 0 35 12" id="pro"><path fill="#fff" d="M4.17.09H0V11.9h.85V8.06h3.32c2.93 0 4.7-1.5 4.7-3.98C8.86 1.57 7.1.1 4.16.1zm0 7.18H.85V.87h3.32C6.67.86 8 2.02 8 4.06c0 2.03-1.33 3.2-3.83 3.2zm16.6 4.64l-2.91-4.14a3.62 3.62 0 002.72-3.7c0-2.5-1.76-3.99-4.68-3.99h-4.18v11.83h.85V8.04h3.33c.4 0 .76-.03 1.13-.08l2.77 3.95h.97zm-8.2-4.63V.86h3.33c2.49 0 3.82 1.17 3.82 3.21 0 2.03-1.33 3.22-3.82 3.22h-3.33zM28.63 12c3.46 0 6.05-2.55 6.05-6s-2.6-6-6.05-6c-3.48 0-6.06 2.57-6.06 6s2.58 6 6.06 6zm0-.8a5.07 5.07 0 01-5.2-5.2c0-3 2.22-5.2 5.2-5.2A5.07 5.07 0 0133.8 6c0 3-2.22 5.2-5.18 5.2z"></path></symbol><symbol viewBox="0 0 32 32" id="search"><path d="m27.64 25.91-7.16-7.16a9.13 9.13 0 0 0-.8-12.06A9.12 9.12 0 0 0 13.18 4c-2.45 0-4.75.96-6.49 2.7A9.12 9.12 0 0 0 4 13.18c0 2.45.96 4.76 2.7 6.5a9.12 9.12 0 0 0 12.05.8l7.16 7.15a1.22 1.22 0 0 0 1.73 0c.48-.48.48-1.25 0-1.73zM8.42 17.95a6.7 6.7 0 0 1 0-9.53 6.7 6.7 0 0 1 9.52 0 6.7 6.7 0 0 1 1.98 4.77 6.7 6.7 0 0 1-11.5 4.76z"></path></symbol><symbol viewBox="0 0 28 24" id="temple"><path d="M14.16.39l11.35 4.08a.98.98 0 01.6 1.27 1 1 0 01-1.28.59l-11.14-4-11.42 4.1A1 1 0 011 5.83a.98.98 0 01.59-1.26L13.3.35a1 1 0 01.85.04zM24 8a1 1 0 01-1 1H4a1 1 0 110-2h19a1 1 0 011 1zM8 11a1 1 0 01-1 1v5a1 1 0 01-2 0v-5a1 1 0 010-2h2a1 1 0 011 1zm14 10a1 1 0 100-2H5a1 1 0 000 2h17zm2 3a1 1 0 000-2H3a1 1 0 000 2h21zM13 11a1 1 0 01-1 1v5a1 1 0 01-2 0v-5a1 1 0 010-2h2a1 1 0 011 1zm4 1a1 1 0 000-2h-2a1 1 0 000 2v5a1 1 0 002 0v-5zm6-1a1 1 0 01-1 1v5a1 1 0 01-2 0v-5a1 1 0 010-2h2a1 1 0 011 1z"></path></symbol><symbol viewBox="0 0 20 23" id="transcripts"><path d="M12.98 7.9a1 1 0 00.14-.12l5.66-5.66A1 1 0 0017.36.71l-5.08 5.08-3.16-3.15a1 1 0 00-1.08-.23 1 1 0 00-.68.3L1.71 8.36a1 1 0 101.41 1.42l5.16-5.16 3.28 3.28a1 1 0 001.41 0zM1 13a1 1 0 100 2h18a1 1 0 100-2H1zm0 4a1 1 0 100 2h18a1 1 0 100-2H1zm-1 5a1 1 0 011-1h8a1 1 0 110 2H1a1 1 0 01-1-1z"></path></symbol><symbol fill="none" id="warning"><path d="M18 36a18 18 0 1 0 0-36 18 18 0 0 0 0 36z" fill="#C9392C"></path><path fill-rule="evenodd" clip-rule="evenodd" d="M19.7 9.7a2 2 0 0 0-3.4 0L8.2 22.97A2 2 0 0 0 9.92 26h16.16a2 2 0 0 0 1.7-3.04L19.72 9.7zm-.46 7.51v-3.94h-2.11v3.94c0 .43.02.85.08 1.27.05.41.12.83.2 1.26h1.54c.09-.43.16-.85.2-1.26.06-.42.09-.84.09-1.27zm-2.27 4.56a1.18 1.18 0 0 0 0 .93c.07.15.16.27.27.38a1.4 1.4 0 0 0 .92.34 1.39 1.39 0 0 0 .91-.34c.12-.11.2-.23.27-.38a1.1 1.1 0 0 0 0-.93 1.1 1.1 0 0 0-.27-.37 1.3 1.3 0 0 0-.91-.34c-.18 0-.35.03-.5.1a1.1 1.1 0 0 0-.69.61z" fill="#fff"></path></symbol></defs></svg></span><div class="root" id="root"><div class="pB zA zR zU"><header class="dqA ejA ddC hideTopBars"><nav aria-label="Main" class="dqB"><div class="ilA irB bpA irA"><div class="fbA baDP baEU ilB zA zC zK fbC" data-test-id="grid-container"><div class="ilC zA zC"><div class="irC"><div class="ikA"><button class="ikB zA zC" data-test-id="hamburger-menu-button" type="button" aria-label="Main menu" aria-controls="hamburger-menu" aria-haspopup="true" aria-expanded="false"><span class="ikC bmD"><span class="ikD bmC"></span></span></button></div></div><a data-test-id="logo" title="Home" aria-label="Seeking Alpha - Go to Homepage" class="hpA zA zR" href="/?source=content_type%3Areact%7Csource%3Asite_navigation"><span class="hpH zA zO"><svg class="hpB hpI hpD"><use xlink:href="#logo"></use></svg></span><span class="hpK">Seeking Alpha - Go to Homepage</span></a></div><div class="ilC zA zC"></div></div></div><div class="ddB bpA ddC ddA"><div class="fbA baDP baEU jkA jkB fbC" data-test-id="grid-container"><nav aria-label="Primary" class="jkC jkD" data-test-id="sub-navigation"><ul class="tcA zU zA zK baCC"><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-trending"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="trending" data-test-id="trending" href="/?source=content_type%253Areact%257Csource%253Aheadtabs">Trending</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-my-portfolio"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="my-portfolio" data-test-id="my-portfolio" href="/account/portfolio?source=content_type%253Areact%257Csource%253Aheadtabs">My Portfolio</a></div><div class="woD swD baH baB6 baW baBH badB wsA zA zR woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-my-authors"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="my-authors" data-test-id="my-authors" href="/account/people?source=content_type%253Areact%257Csource%253Aheadtabs">My Authors</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-top-stocks"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="top-stocks" data-test-id="top-stocks" href="/screeners?source=content_type%253Areact%257Csource%253Aheadtabs">Top Stocks</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-latest-news"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="latest-news" data-test-id="latest-news" href="/market-news?source=content_type%253Areact%257Csource%253Aheadtabs">Latest News</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-markets"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="markets" data-test-id="markets" href="/market-outlook?source=content_type%253Areact%257Csource%253Aheadtabs">Markets</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-stock-ideas"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="stock-ideas" data-test-id="stock-ideas" href="/stock-ideas?source=content_type%253Areact%257Csource%253Aheadtabs">Stock Ideas</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-dividends"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="dividends" data-test-id="dividends" href="/dividends?source=content_type%253Areact%257Csource%253Aheadtabs">Dividends</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-etfs"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="et-fs" data-test-id="et-fs" href="/etfs-and-funds?source=content_type%253Areact%257Csource%253Aheadtabs">ETFs</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-education"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="education" data-test-id="education" href="/education?source=content_type%253Areact%257Csource%253Aheadtabs">Education</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li><li class="badD zW"><div class="woA zA zC woM badA baC baB1 ba0 baBL"><div class="swA badC woB" data-test-id="head-nav-link-button-watch-and-listen"><div class="bgbB zA zC"><a class="blkA zA zC" aria-expanded="false" aria-haspopup="true" data-scroll-id="watch-listen" data-test-id="watch-listen" href="/podcast?source=content_type%253Areact%257Csource%253Aheadtabs">Watch &amp; Listen</a></div><div class="woD swD baH baB6 baW baBH badB woO" style="transform:translate3d(0px, 0px, 0px)"></div></div></div></li></ul></nav></div><div></div></div></nav></header><main class="pD zA zR zU bpA pE" id="content"><div class="dA zA zR zU cardsLayout"><div class="bwA zA zR zU"><article class="fbA baDP baEU jqA fbE" data-test-id="article-page"><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://seekingalpha.com/news/3693503-live-nation-stock-jumps-7-amid-signs-of-life-as-analysts-look-to-concert-rebound"},"author":{"@type":"Person","name":"Jason Aycock","url":"https://seekingalpha.com/user/427396/profile"},"publisher":{"@type":"Organization","name":"Seeking Alpha","logo":{"@type":"ImageObject","height":60,"url":"https://seekingalpha.com/samw/static/images/PublisherLogo.1a0fb372.png","width":360}},"datePublished":"2021-05-07T19:24:14.000Z","dateModified":"2021-05-07T19:24:14.000Z","description":"Live Nation Entertainment (LYV) is up 6.7% after yesterday's Q1 earnings, where the company edged some heavily lowered revenue expectations and began to plot its way out of...","headline":"Live Nation jumps 7% amid signs of life as analysts look to concert rebound","about":[{"@type":"Corporation","name":"Live Nation Entertainment, Inc.","tickerSymbol":"NYSE:LYV","url":"https://seekingalpha.com/symbol/LYV"},{"@type":"Corporation","name":"Live Nation Entertainment, Inc.","tickerSymbol":"NYSE:LYV","url":"https://seekingalpha.com/symbol/LYV"}],"image":{"@type":"ImageObject","url":"https://static.seekingalpha.com/assets/og_image_1200-29b2bfe1a595477db6826bd2126c63ac2091efb7ec76347a8e7f81ba17e3de6c.png"},"isAccessibleForFree":"False","hasPart":[{"@type":"WebPageElement","isAccessibleForFree":"False","cssSelector":".paywall-full-summary"},{"@type":"WebPageElement","isAccessibleForFree":"False","cssSelector":".paywall-full-content"}]}</script><div class="naA naK naE naI" data-test-id="grid-row"><div class="liB liDX" data-test-id="grid-col"><div class="hyA ejA bmA" data-test-id="left-rail"><div></div></div></div><div class="liB8 liDX" data-test-id="grid-col"><div class="" data-test-id="article-section"><div class="rxA zA zK zR ezA baDP baEU ibB ibJ baN ibK ibC baF8" data-test-id="card-container"><div class="ibO zA zN"><div class="ibM"><div class="xeA baL ba5 baBQ"><header class="bacA zA zD zK zR"><div class="kqA baGI zA zC zI"><div class="tvA" data-test-id="themes-list"><ul class="tvB zA"><li class="tvC zA zC baF8"><a data-test-id="theme-links-item" class="efC bcsA efF ba2 baBN boI boW boD" href="/market-news/on-the-move?source=content_type%3Areact%7Csection%3Amain_content%7Csection_asset%3Athemes%7Cbutton%3Aon-the-move%7Cfirst_level_url%3Anews"><span class="tvD koC">On the Move</span></a></li><li class="tvC zA zC baF8"><a data-test-id="theme-links-item" class="efC bcsA efF ba2 baBN boI boW boD" href="/earnings/earnings-news?source=content_type%3Areact%7Csection%3Amain_content%7Csection_asset%3Athemes%7Cbutton%3Aearnings%7Cfirst_level_url%3Anews"><span class="tvD koC">Earnings News</span></a></li></ul></div><button aria-expanded="false" aria-label="Share options" class="ewC ewA zW zA zC zH ewL boK boY boA ewG kqC" data-test-id="custom-share-button" type="button"><span class="ewP gwA"><svg viewBox="0 0 18 18" xmlns="http://www.w3.org/2000/svg" class="kqB baD0"><path d="M14.8 17.14a2.7 2.7 0 0 1-2.13-2.7l.01-.3-3.88-1.73-3.97-1.77c-.07-.03-.11 0-.3.17a2.67 2.67 0 1 1 0-3.83l.23.23 3.96-1.77 3.96-1.76-.01-.3c-.04-.7.24-1.44.74-1.97.64-.67 1.7-.96 2.6-.72A2.73 2.73 0 0 1 18 3.13a2.67 2.67 0 0 1-4.56 2.02l-.19-.18L9.3 6.73 5.33 8.5v.83l3.94 1.75 3.95 1.76.24-.22a2.67 2.67 0 1 1 1.35 4.52z"></path></svg></span></button></div><div class="ksB zA zK"><h1 class="ksA baGI boQ bo9 boD boCB boDW boEE" data-test-id="post-title">Live Nation jumps 7% amid signs of life as analysts look to concert rebound</h1></div><div class="ksC zA zK baGI boJ boZ boA" data-test-id="post-page-meta"><div><span class="ksD ksF bmB" data-test-id="post-date">May 07, 2021 3:24 PM ET</span><span class="ksF bmB" data-test-id="post-primary-tickers"><a class="bblA" href="/symbol/LYV?source=content_type%3Areact%7Csection%3Amain_content%7Csection_asset%3Ameta%7Cfirst_level_url%3Anews%7Csymbol%3ALYV">Live Nation Entertainment, Inc. (LYV)</a></span><span class="ksD ksF bmB" data-test-id="post-secondary-tickers"><span><a class="bboD" href="/symbol/LYV?source=content_type%3Areact%7Csection%3Amain_content%7Csection_asset%3Ameta%7Cfirst_level_url%3Anews%7Csymbol%3ALYV">LYV</a></span></span><span class="ksF bmB" data-test-id="post-author-nick"><a class="ksK" href="/user/427396/profile?source=content_type%3Areact%7Csection%3Amain_content%7Csection_asset%3Ameta%7Cbutton%3Aauthor_name%7Cfirst_level_url%3Anews">By: Jason Aycock</a>, <span class="ksD">SA News Editor</span></span><span class="ksG bmD"><a class="ksI boJ boZ boA" data-test-id="post-comments-count" href="#comments" id="commentsPianoElement">1 Comment</a></span></div></div></header><div><div class="lnA zA" data-test-id="article-content"><div class="lnB zU"><div class="lnH" data-test-id="content-container"><ul> <li>Live Nation Entertainment <span class="ticker-hover-wrapper">(NYSE:<a href="https://seekingalpha.com/symbol/LYV" title="Live Nation Entertainment, Inc.">LYV</a>)</span> is <span class="green">up 6.7%</span> after yesterday's <a href="https://seekingalpha.com/news/3692511-live-nation-entertainment-eps-beats-0_19-beats-on-revenue?source=content_type%3Areact%7Csection%3AAll%7Csection_asset%3ANews%7Cfirst_level_url%3Asymbol%7Cbutton%3ATitle%7Clock_status%3ANo%7Cline%3A3" target="_blank">Q1 earnings</a>, where the company edged some heavily lowered<span class="paywall-full-content"> revenue expectations and began to plot its way out of the low-revenue environment of the COVID-19 lockdowns.</span> </li> <li class="paywall-full-content">Revenues fell nearly 79% and operating income fell about 76%. The company estimated it ran 664 events worldwide in Q1, vs. a previous-year Q1 total of 7,095.</li> <li class="paywall-full-content">The company said that $1.1B in free cash and available debt capacity gives it $2.1B in liquidity, which should allow for funding until an expected return of concerts this summer.</li> <li class="paywall-full-content">Berenberg noted that on the <a href="https://seekingalpha.com/article/4425354-live-nation-entertainment-inc-lyv-ceo-michael-rapino-on-q1-2021-results-earnings-call?source=content_type%3Areact%7Csection%3AAll%7Csection_asset%3ANews%7Cfirst_level_url%3Asymbol%7Cbutton%3ATitle%7Clock_status%3ANo%7Cline%3A1" target="_blank">conference call</a>, the company said sales for tickets to New York's Governor's Ball had their best-ever first day, while big festivals Bonnaroo, Electric Daisy and Rolling Loud all sold out at full capacity in record time.</li> <li class="paywall-full-content">That indicates that "demand (initially, at least, and primarily for outdoor events) is ample enough to soak up a compressed level of supply,” Berenberg says.</li> <li class="paywall-full-content">And Cowen expects the company has 46 fests scheduled between June and November, about 41% of 2019 levels. The firm is bullish on outcomes due to pent-up supply and demand, and has a $100 price target, implying 25% upside.</li> <li class="paywall-full-content">Berenberg is Neutral with an $85 target, and J.P. Morgan weighs in saying it sees risk/reward balanced where shares are now (it has a $75 price target vs. today's $80.04 price).</li> <li class="paywall-full-content"><a href="https://seekingalpha.com/pr/18306614-live-nation-entertainment-reports-first-quarter-2021-results?source=content_type%3Areact%7Csection%3Amain_content%7Cbutton%3Abody_link%7Cfirst_level_url%3Anews" target="_blank">Press release</a></li> <li class="paywall-full-content"><a href="https://seekingalpha.com/article/4425354-live-nation-entertainment-inc-lyv-ceo-michael-rapino-on-q1-2021-results-earnings-call?source=content_type%3Areact%7Csection%3AAll%7Csection_asset%3ANews%7Cfirst_level_url%3Asymbol%7Cbutton%3ATitle%7Clock_status%3ANo%7Cline%3A1" target="_blank">Earnings call transcript</a></li> </ul></div><div class="above_now_read-piano-placeholder lnE"></div></div></div></div><div class="piano-paywall-container"></div></div></div></div></div></div></div><div class="liP liBI liDX" data-test-id="grid-col"><div class="hyB ejA zA zR baCA" data-test-id="right-rail"><div></div></div></div></div></article></div></div></main></div><div class="gA baG4 baDP baEU baFZ ba1 baBM zA zI" id="google-one-tap-popup-container"></div><div class="jA bmA" id="px-captcha-wrapper"><div class="jB baG4 baDP baEU baFZ baL baCA"><div><div id="px-captcha"></div><div><div class="jC baGG">To ensure this doesn’t happen in the future, please enable Javascript and cookies in your browser.</div><div class="jC baGG">Is this happening to you frequently? Please <a href="https://seekingalpha.userecho.com/?source=captcha">report it on our feedback forum.</a></div><div class="jC baGG">If you have an ad-blocker enabled you may be blocked from proceeding. Please disable your ad-blocker and refresh.</div></div><div class="px-reference-id"></div></div></div></div></div><noscript><iframe height="0" src="https://www.googletagmanager.com/ns.html?id=GTM-PFXR76F" style="display:none;visibility:hidden" title="google-tag-manager" width="0"></iframe></noscript><script async src="/samw/static/js/app.5cbcc155.js"></script></body></html>